Страница 33 из 33 ПерваяПервая ... 2327282930313233
Показано с 321 по 329 из 329
  1. #321
    Администратор Аватар для Chip
    Регистрация
    08.06.2007
    Возраст
    49
    Сообщений
    13,297
    Вес репутации
    10

    По умолчанию Re: AVC-Lan адаптер на arduino

    Ругается на то что не установлены библиотеки AVCLanDrv и BuffSerial


  2. #322
    Новичок
    Регистрация
    19.07.2018
    Сообщений
    1
    Вес репутации
    0

    По умолчанию Re: AVC-Lan адаптер на arduino

    Всем привет. Авто - Toyota Crown Majesta UZS173. Собрал адаптер на ST485. Все работает, сообщения все вижу, но нави не активируется. Может я что-то не так сделал? Слышал проблему в методе AvcLanDrv - readAcknowledge(). Попробую конечно поправить, но вопрос в другом. Как нужно было подключаться в шину? Полностью отключить родной блок от шины и регаться только адаптером и все должно заработать или нужно фишку не отключать от родного блока нави, а просто параллельно врезаться в провода шины, что бы и родной блок что-то отвечал и активировал RGB.

    Сейчас у меня не активируется нави, реакции нет на кнопках нави. Но адаптером могу управлять громкостью если отправить директ на усилок (для примера). Есть подозрение, что сообщения регистрации не прохродят в шину, по крайней мере в терминале я их не вижу (те что от самого эмулятора должны идти). В коде я их вижу, по факту нет их в шине. Если забивать ручками их через терминал слышно что звук прерывается на секунду, что-то происходит, но сама прошивка не может зарегать.
    Последний раз редактировалось Lemmur; 19.07.2018 в 14:05.

  3. #323
    Новичок
    Регистрация
    01.08.2016
    Возраст
    29
    Сообщений
    13
    Вес репутации
    36

    По умолчанию Re: AVC-Lan адаптер на arduino

    Цитата Сообщение от Lemmur Посмотреть сообщение
    Всем привет. Авто - Toyota Crown Majesta UZS173. Собрал адаптер на ST485. Все работает, сообщения все вижу, но нави не активируется. Может я что-то не так сделал? Слышал проблему в методе AvcLanDrv - readAcknowledge(). Попробую конечно поправить, но вопрос в другом. Как нужно было подключаться в шину? Полностью отключить родной блок от шины и регаться только адаптером и все должно заработать или нужно фишку не отключать от родного блока нави, а просто параллельно врезаться в провода шины, что бы и родной блок что-то отвечал и активировал RGB.

    Сейчас у меня не активируется нави, реакции нет на кнопках нави. Но адаптером могу управлять громкостью если отправить директ на усилок (для примера). Есть подозрение, что сообщения регистрации не прохродят в шину, по крайней мере в терминале я их не вижу (те что от самого эмулятора должны идти). В коде я их вижу, по факту нет их в шине. Если забивать ручками их через терминал слышно что звук прерывается на секунду, что-то происходит, но сама прошивка не может зарегать.
    блок нужно отключить, посмотри readonly. Нужно чтоб 00 было, голову в еепром забей или авто сделай

  4. #324
    Новичок
    Регистрация
    21.10.2018
    Сообщений
    1
    Вес репутации
    0

    По умолчанию Re: AVC-Lan адаптер на arduino

    Всем привет. Понимаю что тема мертва, но может хоть кто-то заходит и может подсказать что делать?
    Дело вот в чем..
    Собрал все предложенные варианты адаптеров, залил прошивку в arduino и вот незадача - CD ченджер не эмулируется.
    В терминале все сообщения от головы (W58814) приходят, правда иногда бывают пропуски.
    Адрес головы 190..
    Всю голову уже сломал и даже не знаю что и делать.
    Может кто подсказать как на этой голове эмулировать CD ченджер?
    Очень нужно балансный вход включить, а не получается.

  5. #325
    Новичок
    Регистрация
    17.01.2019
    Сообщений
    3
    Вес репутации
    0

    По умолчанию Re: AVC-Lan адаптер на arduino

    Помогите пожалуйста, не могу скомпилировать ни одного скачанного здесь проекта ни в avrstudio ни в arduino, ругается на различные ошибки, пробовал с разными версиями, ничего не помогает.
    Хотелось бы проект открыть в ардуино для Nano. чтоб допилить кое-что по функциям, но не выходит, в ардуино не совсем на ты, больше по железу....

  6. #326
    Администратор Аватар для Chip
    Регистрация
    08.06.2007
    Возраст
    49
    Сообщений
    13,297
    Вес репутации
    10

    По умолчанию Re: AVC-Lan адаптер на arduino

    Все писалось давно, на очень древних версиях IDE

  7. #327
    Новичок
    Регистрация
    17.01.2019
    Сообщений
    3
    Вес репутации
    0

    По умолчанию Re: AVC-Lan адаптер на arduino

    Цитата Сообщение от Chip Посмотреть сообщение
    Все писалось давно, на очень древних версиях IDE
    допустим с версией 018 еще компилировать проект получается, но выдает он с магнитолы в терминал всё ровно кракозявки, есть ли возможность портировать проект на более новые версии софта?

  8. #328
    Новичок
    Регистрация
    24.01.2019
    Сообщений
    1
    Вес репутации
    0

    По умолчанию Re: AVC-Lan адаптер на arduino

    Доброго времени суток всей чесной компании. Прошу пнуть в нужную сторону. При сборке проекта требует "wiring.h". Чё за зверь, как написать или где лежит?

  9. #329
    Новичок
    Регистрация
    17.01.2019
    Сообщений
    3
    Вес репутации
    0

    По умолчанию Re: AVC-Lan адаптер на arduino

    скачайте старую версию ардуино 0.18

Страница 33 из 33 ПерваяПервая ... 2327282930313233

Информация о теме

Пользователи, просматривающие эту тему

Эту тему просматривают: 1 (пользователей: 0 , гостей: 1)

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •